0
Answered

black edges showing up after lighting standard shader. any ideas why? :/

Fab 2 months ago updated by jackielo 2 months ago 5

i only changed shader type to sprite and sprite light to diffuse than those edges showed up. im pretty sure this is not a shaderweave problem though ^^ must have something to do with anything on my side. but when i choose different sprites or start a new program they appear too. thankful for any help ! :)

Answer

Answer
Answered

SW contains 4 blend mode

Off: Blend Off

Blend : Blend SrcAlpha OneMinusSrcAlpha

Add:Blend SrcAlpha One

Mul:Blend zero SrcColor

For the rest you need to do them in shader code.

Sorry for the inconvenience.

ok i changed

Blend SrcAlpha OneMinusSrcAlpha 

to 

Blend One OneMinusSrcAlpha

i hope this helps someone it took me days xD

is their an option to do this without going into the shadercode? if not it would be really cool to have an option for this :). otherwise really cool asset ! im glad i bought it 

Under review

Good Job!

Answer
Answered

SW contains 4 blend mode

Off: Blend Off

Blend : Blend SrcAlpha OneMinusSrcAlpha

Add:Blend SrcAlpha One

Mul:Blend zero SrcColor

For the rest you need to do them in shader code.

Sorry for the inconvenience.

also is there any possibility to render things in world space for shading multiple sprites as one? im not a pro in shaders but if thats possible it would be really cool

Shader Weaver is designed for individual object effect, but you can share same Shader Weaver Material among objects/