0
Not a bug

Shaders not working with Sprite Atlas

smasha01 3 weeks ago updated by jackielo 2 weeks ago 6

Hi,

My shaders are not working well with images used in sprite atlas. If i remove the images from the atlas they work perfectly.


Left image is no sprite atlas, right image is with sprite atlas

https://streamable.com/s585mz


Video of the shader

https://streamable.com/63fpri

Unity 2019.4.19f1

Shaderweaver 1.7.1

Under review

Hi I cannot open the links you provide,

Would you please just upload the image here directly?

Hi Jackielo,

Thanks for your reply. Here is a screenshot of the shader and the issue im facing. The left side is without sprite atlas, and the right side is with sprite atlas. I have also changed the shader type to "UI" and others and it doesnt help solve the issue.

Added gif instead of static image


Whats your way of using atlas.

1. In texture's inspector ,Sprite Mode> Multiple

2. Editor Settings  -> Sprite Packer> Always enable

3. Create a atlas like this


Which way are you using, and what textures/Sprites use for, root texture only?


I tested all 3 moethods, it seems OK.


By the way.

In SW, the Default mode is used for mesh like 'Plane' and 'Quad',and if for a Sprite Renderer, you must choose Sprite mode.

And you can send the related assets to JackieLo@aliyun.com if you like.

I had to use "sprite mode as multiple" thank you! Now it is working well :)

The readme doesnt mention this, is there some other documentaiton to read as well? Thanks!

Not a bug

It is my pleasure. It will be great if you can give Shader Weaver a review on assetstore page, thank you!